Blender PT

Blender 3D, Modelação, Renderização, Arte tudo em Português

Você não está autenticado.

#1 2016-04-14 22:25:42

Mei
Membro
Registado: 2016-04-14
Mensagens: 1

Bug na textura

Estou com problemas na hora de usar o texture paint, o objeto fica com linhas pretas e não sei como resolver, tentei mapear o uv de vários jeitos mas ainda continua
ynmqG0N.png

Só quando pinto o fundo do uv da mesma cor do objeto ele tira as linhas, já tentei colocar o fundo do uv com transparência mas continua com as linhas pretas, tem como arrumar isso sem ter que pintar o fundo?
BBu3oUn.png

Offline

#2 2016-04-15 23:25:35

zeroshift
Moderator
De: Palmela
Registado: 2013-02-24
Mensagens: 291

Re: Bug na textura

Olá

Tens de incluir umas margens nos limites das arestas dos UV, com a cor ou textura em uso na face. É normal porque o processador gráfico tenta interpolar a cor com a coordenada do ponto do UV entre vários pixeis da textura (imagina uma "média"), por isso os pixeis na proximidade podem ser usados. Claro que pode-se amostrar só um pixel, mas esse modo dá um efeito de "pixel art" da textura nos modelos 3D.

Creio se fizeres um bake no Blender, ele tem uma opção de definir as margens, já a pensar nisso.

Há outras coisas mais complexas que o GPU faz por defeito, que é o mipmaping, que é fazer texturas de menor resolução para acelerar o desenho e melhorar a qualidade com a distância que ainda pioram mais este problema, se não tiver bem resolvido logo ao inicio.

Cumprimentos

Offline

#3 2016-04-18 09:32:12

jnascimento
Membro
De: Coimbra
Registado: 2013-02-24
Mensagens: 327

Re: Bug na textura

Boas,
Como não mostras os UVs, não sei se elas não estão demasiado próximas umas das outras. Se for o caso pode haver bleed de cor.  Quando fazes Unwrap podes definir a margem.

UC8lU.png

("margin")


Atualmente a brincar com: Blender, Substance Designer & Painter, UE4

Offline

Rodapé do site